$re = '/^(.*([^\nw].{5}|.[^\no].{4}|.{2}[^\nr].{3}|.{3}[^\nl].{2}|.{4}[^\nd].|.{5}[^\n.])|.{0,5})$/m';
$str = '1
12
123
1234
12345
123456
Hello, world.
Hello, world
Hello, world.
^ Spaces added ^';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);