const regex = /^(.*([^\nw].{5}|.[^\no].{4}|.{2}[^\nr].{3}|.{3}[^\nl].{2}|.{4}[^\nd].|.{5}[^\n.])|.{0,5})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*([^\\nw].{5}|.[^\\no].{4}|.{2}[^\\nr].{3}|.{3}[^\\nl].{2}|.{4}[^\\nd].|.{5}[^\\n.])|.{0,5})$', 'gm')
const str = `1
12
123
1234
12345
123456
Hello, world.
Hello, world
Hello, world.
^ Spaces added ^`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}