import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!^count$|^find$).+";
final String string = "sku\n"
+ "count\n"
+ "find\n"
+ "countfind\n"
+ "findcount\n"
+ "skucount\n"
+ "skufind\n"
+ "countsku\n"
+ "findsku\n"
+ "coun\n"
+ "fin\n"
+ "ount\n"
+ "ind\n"
+ "skucoun\n"
+ "skufin\n"
+ "finsku\n"
+ "counsku";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}