$re = '/^(?!^count$|^find$).+/um';
$str = 'sku
count
find
countfind
findcount
skucount
skufind
countsku
findsku
coun
fin
ount
ind
skucoun
skufin
finsku
counsku';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);