re = /^(?!^count$|^find$).+/m
str = 'sku
count
find
countfind
findcount
skucount
skufind
countsku
findsku
coun
fin
ount
ind
skucoun
skufin
finsku
counsku'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end