#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{2}:) (\d{2}:) ([0-9,]+) -> (\d{2}:) (\d{2}:) ([0-9,]+)"
Local $sString = "7" & @CRLF & _
"00: 00: 20,509 -> 00: 00: 25,059" & @CRLF & _
"on the data before and does not shy in front of radical solutions such as post privacy back." & @CRLF & _
"" & @CRLF & _
"8" & @CRLF & _
"00: 00: 25,159 -> 00: 00: 27,896" & @CRLF & _
"On his blog writes: sower already since 2011" & @CRLF & _
"" & @CRLF & _
"9" & @CRLF & _
"00: 00: 27,996 -> 00: 00: 31,784" & @CRLF & _
"on the impact of technology on society, politics and economy."
Local $sSubst = "\1\2\3-->\4\5\6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)