// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{2}:) (\d{2}:) ([0-9,]+) -> (\d{2}:) (\d{2}:) ([0-9,]+)").unwrap();
let string = "7
00: 00: 20,509 -> 00: 00: 25,059
on the data before and does not shy in front of radical solutions such as post privacy back.
8
00: 00: 25,159 -> 00: 00: 27,896
On his blog writes: sower already since 2011
9
00: 00: 27,996 -> 00: 00: 31,784
on the impact of technology on society, politics and economy.";
let substitution = "\\1\\2\\3-->\\4\\5\\6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}