# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{2}:) (\d{2}:) ([0-9,]+) -> (\d{2}:) (\d{2}:) ([0-9,]+)"
test_str = ("7\n"
"00: 00: 20,509 -> 00: 00: 25,059\n"
"on the data before and does not shy in front of radical solutions such as post privacy back.\n\n"
"8\n"
"00: 00: 25,159 -> 00: 00: 27,896\n"
"On his blog writes: sower already since 2011\n\n"
"9\n"
"00: 00: 27,996 -> 00: 00: 31,784\n"
"on the impact of technology on society, politics and economy.")
subst = "\\1\\2\\3-->\\4\\5\\6"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.