import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2}:) (\\d{2}:) ([0-9,]+) -> (\\d{2}:) (\\d{2}:) ([0-9,]+)";
final String string = "7\n"
+ "00: 00: 20,509 -> 00: 00: 25,059\n"
+ "on the data before and does not shy in front of radical solutions such as post privacy back.\n\n"
+ "8\n"
+ "00: 00: 25,159 -> 00: 00: 27,896\n"
+ "On his blog writes: sower already since 2011\n\n"
+ "9\n"
+ "00: 00: 27,996 -> 00: 00: 31,784\n"
+ "on the impact of technology on society, politics and economy.";
final String subst = "\\1\\2\\3-->\\4\\5\\6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}