package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<country>[A-Z]\-)?(?<plz>[0-9]{5})(?<separator>,? )(?<location>.+)`)
var str = `D-10115 Berlin
80331 München
60311, Frankfurt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}