const regex = /(?<country>[A-Z]\-)?(?<plz>[0-9]{5})(?<separator>,? )(?<location>.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<country>[A-Z]\\-)?(?<plz>[0-9]{5})(?<separator>,? )(?<location>.+)', 'g')
const str = `D-10115 Berlin
80331 München
60311, Frankfurt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}