re = /(?<country>[A-Z]\-)?(?<plz>[0-9]{5})(?<separator>,? )(?<location>.+)/
str = 'D-10115 Berlin
80331 München
60311, Frankfurt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end