import Foundation
let pattern = #"(?<country>[A-Z]\-)?(?<plz>[0-9]{5})(?<separator>,? )(?<location>.+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
D-10115 Berlin
80331 München
60311, Frankfurt
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)