#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=[\S\s])$"
Local $sString = "dlafad asf as" & @CRLF & _
"df asdfaf asdf asdf " & @CRLF & _
"af " & @CRLF & _
"sdf a" & @CRLF & _
"sd fadsfasdf aff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")