using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\S\s])$";
string input = @"dlafad asf as
df asdfaf asdf asdf
af
sdf a
sd fadsfasdf aff";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}