re = /(?<=[\S\s])$/
str = 'dlafad asf as
df asdfaf asdf asdf
af
sdf a
sd fadsfasdf aff'
# Print the match result
str.match(re) do |match|
puts match.to_s
end