$re = '/(?<=[\S\s])$/';
$str = 'dlafad asf as
df asdfaf asdf asdf
af
sdf a
sd fadsfasdf aff';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);