import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-f\\d\\-]+ # Matches a-f, any digit, - (hyphen)\n"
+ " # ^ One or more times (+)\n"
+ "\\/ # Matches a /\n"
+ ".+ # Matches any character one or more times\n"
+ "\\. # Matches a . (dot)\n"
+ "(?i) # States that anything after this is case-insesitive\n"
+ " # ^ Inline Flag\n"
+ "(jpg|jpeg|gif|png) # Selects file extension\n"
+ " # ^ (either jpg, jpeg, gif, or png)\n"
+ "(?-i) # Removes Inline Flag";
final String string = "\"/stories/main_imagescache/20160319-1549-2202-5826/blueapronimage.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}