re = /[a-f\d\-]+ # Matches a-f, any digit, - (hyphen)
# ^ One or more times (+)
\/ # Matches a \/
.+ # Matches any character one or more times
\. # Matches a . (dot)
(?i) # States that anything after this is case-insesitive
# ^ Inline Flag
(jpg|jpeg|gif|png) # Selects file extension
# ^ (either jpg, jpeg, gif, or png)
(?-i) # Removes Inline Flag/x
str = '"/stories/main_imagescache/20160319-1549-2202-5826/blueapronimage.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end