const regex = /[a-f\d\-]+ # Matches a-f, any digit, - (hyphen)
# ^ One or more times (+)
\/ # Matches a /
.+ # Matches any character one or more times
\. # Matches a . (dot)
(?i) # States that anything after this is case-insesitive
# ^ Inline Flag
(jpg|jpeg|gif|png) # Selects file extension
# ^ (either jpg, jpeg, gif, or png)
(?-i) # Removes Inline Flag/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-f\\d\\-]+ # Matches a-f, any digit, - (hyphen)
# ^ One or more times (+)
\\\/ # Matches a \/
.+ # Matches any character one or more times
\\. # Matches a . (dot)
(?i) # States that anything after this is case-insesitive
# ^ Inline Flag
(jpg|jpeg|gif|png) # Selects file extension
# ^ (either jpg, jpeg, gif, or png)
(?-i) # Removes Inline Flag', '')
const str = `"/stories/main_imagescache/20160319-1549-2202-5826/blueapronimage.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}