import Foundation
let pattern = ##"""
[a-f\d\-]+ # Matches a-f, any digit, - (hyphen)
# ^ One or more times (+)
\/ # Matches a /
.+ # Matches any character one or more times
\. # Matches a . (dot)
(?i) # States that anything after this is case-insesitive
# ^ Inline Flag
(jpg|jpeg|gif|png) # Selects file extension
# ^ (either jpg, jpeg, gif, or png)
(?-i) # Removes Inline Flag
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #""/stories/main_imagescache/20160319-1549-2202-5826/blueapronimage.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}