using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%(?:aa|cc)%(?!.*%(?:aa|cc)%)";
string substitution = @"";
string input = @"/%aa%/%cc%/bb
=> should replace only %cc%
/%aa%/%cc%/ac
=> should replace only %cc%
/bb/%aa%/%cc%
=> should replace only the last %cc%
/bb/%aa%
=> should replace %aa%
/bb/ac/%aa%/%cc%/ac/bb
=> should replace only the last %cc%";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}