$re = '~%(?:aa|cc)%(?!.*%(?:aa|cc)%)~';
$str = '/%aa%/%cc%/bb
=> should replace only %cc%
/%aa%/%cc%/ac
=> should replace only %cc%
/bb/%aa%/%cc%
=> should replace only the last %cc%
/bb/%aa%
=> should replace %aa%
/bb/ac/%aa%/%cc%/ac/bb
=> should replace only the last %cc%';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;