# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"%(?:aa|cc)%(?!.*%(?:aa|cc)%)"
test_str = ("/%aa%/%cc%/bb\n"
" => should replace only %cc%\n"
"/%aa%/%cc%/ac\n"
" => should replace only %cc%\n"
"/bb/%aa%/%cc%\n"
" => should replace only the last %cc%\n"
"/bb/%aa%\n"
" => should replace %aa%\n"
"/bb/ac/%aa%/%cc%/ac/bb\n"
" => should replace only the last %cc%")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.