import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%(?:aa|cc)%(?!.*%(?:aa|cc)%)";
final String string = "/%aa%/%cc%/bb\n"
+ " => should replace only %cc%\n"
+ "/%aa%/%cc%/ac\n"
+ " => should replace only %cc%\n"
+ "/bb/%aa%/%cc%\n"
+ " => should replace only the last %cc%\n"
+ "/bb/%aa%\n"
+ " => should replace %aa%\n"
+ "/bb/ac/%aa%/%cc%/ac/bb\n"
+ " => should replace only the last %cc%";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}