using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\D*(?>(\d)(?!.*\1)\D*){10}$";
string input = @"e8v5i0l9ny3hw1f24z7q6";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}