const regex = /^\D*(?>(\d)(?!.*\1)\D*){10}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\D*(?>(\\d)(?!.*\\1)\\D*){10}$', '')
const str = `e8v5i0l9ny3hw1f24z7q6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}