$re = '/^\D*(?>(\d)(?!.*\1)\D*){10}$/';
$str = 'e8v5i0l9ny3hw1f24z7q6';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);