import re
regex = re.compile(r"^\D*(?>(\d)(?!.*\1)\D*){10}$")
test_str = "e8v5i0l9ny3hw1f24z7q6"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")