# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\r?\n(?!-)/ /gix;t' <<< "-line 1
line 2
line 3
-line a
line b
line c
"