#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ix)\r?\n(?!-)"
Local $sString = "-line 1" & @CRLF & _
"line 2" & @CRLF & _
"line 3" & @CRLF & _
"-line a" & @CRLF & _
"line b" & @CRLF & _
"line c" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)