using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\r?\n(?!-)";
string substitution = @" ";
string input = @"-line 1
line 2
line 3
-line a
line b
line c
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}