const regex = /\r?\n(?!-)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\r?\\n(?!-)', 'gi')
const str = `-line 1
line 2
line 3
-line a
line b
line c
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);