package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<com\.mfs\.model\.connector\.ConnectorBrowseInfo>\n.+\n.+?<name>(.*?)<\/name>`)
var str = `<com.mfs.model.connector.ConnectorBrowseInfo>
<type>css</type>
<name>Cascading Style Server</name>
<typeGroup>css</typeGroup>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}