re = /<com\.mfs\.model\.connector\.ConnectorBrowseInfo>\n.+\n.+?<name>(.*?)<\/name>/m
str = '<com.mfs.model.connector.ConnectorBrowseInfo>
<type>css</type>
<name>Cascading Style Server</name>
<typeGroup>css</typeGroup>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end