const regex = /<com\.mfs\.model\.connector\.ConnectorBrowseInfo>\n.+\n.+?<name>(.*?)<\/name>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<com\\.mfs\\.model\\.connector\\.ConnectorBrowseInfo>\\n.+\\n.+?<name>(.*?)<\\\/name>', 'gm')
const str = `<com.mfs.model.connector.ConnectorBrowseInfo>
<type>css</type>
<name>Cascading Style Server</name>
<typeGroup>css</typeGroup>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}