import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:http(?:s)?:\\/\\/.*\\/produtos-exclusivos\\/)(.*?)\\b(\\/.*)?$";
final String string = "http://rogeriobonfim.local/produtos-exclusivos/245/sadf/sadf";
final String subst = "$1 $2 $3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}