const regex = /^(?:http(?:s)?:\/\/.*\/produtos-exclusivos\/)(.*?)\b(\/.*)?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:http(?:s)?:\\\/\\\/.*\\\/produtos-exclusivos\\\/)(.*?)\\b(\\\/.*)?$', 'i')
const str = `http://rogeriobonfim.local/produtos-exclusivos/245/sadf/sadf`;
const subst = `$1 $2 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);