$re = '/\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f]/';
$str = '?????????????☺️?????????????????????????????????????????????????????????';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);