re = /\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f]/
str = '?????????????☺️?????????????????????????????????????????????????????????'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end