using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=,|^)(?:[0.+-]+(?=0(?:,|\.\B|$))|0+(?=[1-9]))|\.0+\b|\b0+(?=\d*\.\b)|\.\B|(?<=[1-9])0+(?=,|$)";
string substitution = @"";
string input = @"2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101,-00.,0.,01,1.10,000.,.000,0.000,-004.04";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}