using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(.*\)";
string input = @"France has the best pastries in the world (the fact that they're called ""viennoiserie"", like in ""Vienna"" is obviously irrelevant). France also has the best wine in the world (I also tend to drink entirely too much wine from Slovenia or Veneto, but again this is irrelevant - right?). Another thing where France excel is cheese (did you try Swiss gruyère? You should.)
France has hte best bread in the world (yeah, really (Really, really) Yeah I'm doing my own with flour, but I'd get a fresh French baguette anyday - with a few seeds in and lots of butter to spread)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}