// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(.*\)").unwrap();
let string = "France has the best pastries in the world (the fact that they're called \"viennoiserie\", like in \"Vienna\" is obviously irrelevant). France also has the best wine in the world (I also tend to drink entirely too much wine from Slovenia or Veneto, but again this is irrelevant - right?). Another thing where France excel is cheese (did you try Swiss gruyère? You should.)
France has hte best bread in the world (yeah, really (Really, really) Yeah I'm doing my own with flour, but I'd get a fresh French baguette anyday - with a few seeds in and lots of butter to spread)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}