use strict;
my $str = 'France has the best pastries in the world (the fact that they\'re called "viennoiserie", like in "Vienna" is obviously irrelevant). France also has the best wine in the world (I also tend to drink entirely too much wine from Slovenia or Veneto, but again this is irrelevant - right?). Another thing where France excel is cheese (did you try Swiss gruyère? You should.)
France has hte best bread in the world (yeah, really (Really, really) Yeah I\'m doing my own with flour, but I\'d get a fresh French baguette anyday - with a few seeds in and lots of butter to spread)';
my $regex = qr/\(.*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}