import re
regex = re.compile(r"\(.*\)", flags=re.MULTILINE)
test_str = ("France has the best pastries in the world (the fact that they're called \"viennoiserie\", like in \"Vienna\" is obviously irrelevant). France also has the best wine in the world (I also tend to drink entirely too much wine from Slovenia or Veneto, but again this is irrelevant - right?). Another thing where France excel is cheese (did you try Swiss gruyère? You should.)\n"
"France has hte best bread in the world (yeah, really (Really, really) Yeah I'm doing my own with flour, but I'd get a fresh French baguette anyday - with a few seeds in and lots of butter to spread)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")