using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"b.*?apple(*SKIP)(*F)|apple";
string input = @">Matched
dolphin elephant apple star
dog cat apple banana
>Unmatched
map banana apple dog
>Only the first apple matched, others are unmatched.
map apple banana apple cat
map apple banana apple banana apple
>The first apple and the second apple matched, others are unmatched.
map apple dog apple banana apple banana apple
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}