use strict;
my $str = '>Matched
dolphin elephant apple star
dog cat apple banana
>Unmatched
map banana apple dog
>Only the first apple matched, others are unmatched.
map apple banana apple cat
map apple banana apple banana apple
>The first apple and the second apple matched, others are unmatched.
map apple dog apple banana apple banana apple
';
my $regex = qr/b.*?apple(*SKIP)(*F)|apple/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}