import re
regex = re.compile(r"b.*?apple(*SKIP)(*F)|apple")
test_str = (">Matched\n"
"dolphin elephant apple star\n"
"dog cat apple banana\n\n"
">Unmatched\n"
"map banana apple dog\n\n"
">Only the first apple matched, others are unmatched.\n"
"map apple banana apple cat\n"
"map apple banana apple banana apple\n\n"
">The first apple and the second apple matched, others are unmatched.\n"
"map apple dog apple banana apple banana apple\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")