import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"(\\\\u[a-zA-Z0-9]{4}|\\\\[^u]|[^\\\\\"])*\"(\\s*:)?|\\b(true|false|null)\\b|-?\\d+(?:\\.\\d*)?(?:[eE][+\\-]?\\d+)?|([\\{\\}\\[\\]]))";
final String string = "{\n"
+ " \"a\": 1,\n"
+ " \"b\": \"foo\",\n"
+ " \"c\": [\n"
+ " false,\n"
+ " \"false\",\n"
+ " null,\n"
+ " \"null\",\n"
+ " {\n"
+ " \"d\": {\n"
+ " \"e\": 130000,\n"
+ " \"f\": \"1.3e5\"\n"
+ " }\n"
+ " }\n"
+ " ]\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}