import re
regex = re.compile(r"(?:\"(\\u[a-zA-Z0-9]{4}|\\[^u]|[^\\\"])*\"(\s*:)?|\b(true|false|null)\b|-?\d+(?:\.\d*)?(?:[eE][+\-]?\d+)?|([\{\}\[\]]))")
test_str = ("{\n"
" \"a\": 1,\n"
" \"b\": \"foo\",\n"
" \"c\": [\n"
" false,\n"
" \"false\",\n"
" null,\n"
" \"null\",\n"
" {\n"
" \"d\": {\n"
" \"e\": 130000,\n"
" \"f\": \"1.3e5\"\n"
" }\n"
" }\n"
" ]\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")